Back to overview
Downtime

Cloudflare is down.

Nov 18 at 04:09am PST
Affected services
API
Web App
Video Server
Cloudflare CDN
Bracket
Milu
St. Martin
API
Web App

Resolved
Nov 18 at 07:08am PST

A fix has been implemented from Cloudflare and it looks like everything is running smoothly.

Updated
Nov 18 at 06:45am PST

It looks like they've implemented a fix and the services seems back up to normal.

Created
Nov 18 at 04:09am PST

Cloudflare is down. Primfeed and EasyBloggers are impacted, I don't have any ETA for now sorry.

Follow https://www.cloudflarestatus.com/ for more information.